How to install Linux Mint via USB

  11 years ago

Scope of this tutorial

This tutorial only covers Hybrid ISO images.

Starting with the release of Linux Mint 12 KDE RC, Linux Mint switched to Hybrid ISO images.

Previous releases such as Linux Mint 9, 10, 11, or even the main edition of Linux Mint 12 are not covered by this tutorial.

What is a Hybrid image?

Traditionally, tools such as 'Startup Disk Creator' or 'UNetbootin' were needed to install Linux Mint via USB.

With hybrid images, you can simply write the content of the ISO and make a bootable USB stick which can install Linux Mint by using the 'dd' command.


  • The resulting USB stick will act exactly like a liveCD/DVD.
  • The process is fast and simple
  • Hybrid ISOs are still compatible with Unetbootin and Startup Disk Creator


  • This method deletes all the data present on the USB drive
  • The USB stick isn't persistent (though you can still use Unetbootin to do this).

How to make the USB stick?

Using mintStick

mintStick is installed by default in Linux Mint.

Launch "USB Image Writer" from the menu, select your ISO image and your USB device and press "Write to device".

Using the Terminal

It is really simple. Go to a Terminal and type:

sudo dd if=~/Desktop/linuxmint.iso of=/dev/sdx oflag=direct  bs=1048576

Where '~/Desktop/linuxmint.iso' is the name and location of your downloaded image (located at the desktop in this example) and '/dev/sdx' is the target USB drive. If your system doesn't support 'oflag=direct', you can just leave it out as it is simply intended to speed up the process a bit.

If you don't know about the target USB drive path, run this command and figure out your destination drive.

sudo fdisk -l

Warning: Make sure to set the correct device path, as this process will delete all data that was on the specified device previously!

Remember, don't include an integer for the USB drive, e.g. '/dev/sdx1', as it would refer to the existing partition on that drive and not the drive itself.

When the USB has been properly created by 'dd', there should be an output similar to this:

sudo dd if=~/Desktop/linuxmint.iso of=/dev/sdb oflag=direct bs=1048576
706+1 records in
706+1 records out
740601856 bytes (741 MB) copied, 91.7024 s, 8.1 MB/s

Using Microsoft Windows

From Windows, you can use 'Pendrive Linux Universal USB Installer':

Alternatively, you can use 'Image Writer', an open source project from Launchpad.

Note: You might need to rename the ISO file and change its extension from .iso to .img for it to be accepted by Image Writer. To do this in Windows you can disable the setting 'Hide extensions for known file types' under 'Folder Options'.

Source: This tutorial was inspired by

BenjaminL 3 years ago

Thank you very much

wdinspi 3 years ago

Cool thanks

dsiddens 7 years ago

Hasn't worked for me.

mysoomro 7 years ago

I'm stuck at a point.

I made a USB of mint 18 to install it on my HP Envy TS u110dx. All worked fine except when I boot from USB and choose to run Linuxmint from grub it just show a black screen and stucks there. I waited for a long time but nothing happened.

Any idea or solution??

Leeo97one 8 years ago

Good tutorial!

wisdomlight 8 years ago

can there be an explanation on how to create a live usb using mac.

flos 8 years ago

## Not Booting from a Non UEFI, Legacy Bios computer !!! ##

My laptop is lenovo, 4x Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz,
Memory 6GB. I see the tutorial is 3 years old. I guess that everything Clem wrote in the tutorial worked back then, but now with this latest Mint 17.2 RC and a Non Uefi computer it seems that even the dd command completed ok, the computer still doesn't boot from the USB flash. First of all I am not a programmer, but a gnu/linux beginner(who want to learn more :)) and I thought I should write all the troubleshooting details to save many hours from other beginners time who just want to make a bootable USB flash drive with this release.
Here are the steps i taken: (on Mint 13(64bit) which I have installed now)

-1- on a 4GB USB flash drive I used Gparted to create a msdos Partition Table, and formated with fat32 Filesystem
Device Boot Start End Blocks Id System
/dev/sdb1 2048 7843839 3920896 b W95 FAT32

-2- $ dd if=linuxmint-17.2-cinnamon-64bit-rc.iso of=/dev/sdb
3201856+0 records in
3201856+0 records out
1639350272 bytes (1,6 GB) copied, 595,884 s, 2,8 MB/s

-3- removed the USB flash drive, then plugged it back to check it:
-first with Gparted which said: 'No partition table found on device dev/sdb' and 'File system: unallocated' ; here is a more detailed information in a print screen
-second with: fdisk -l which said:
WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted

Disk /dev/sdb: 4016 MB, 4016046080 bytes
255 heads, 63 sectors/track, 488 cylinders, total 7843840 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3519853a
Device Boot Start End Blocks Id System
/dev/sdb1 * 0 3201855 1600928 0 Empty
/dev/sdb2 59432 63975 2272 ef EFI(FAT-12/16/32)

-4- restarted the computer, and first I tried with the "Multi Boot Menu" which appears on my laptop when i press F12 right after turning on the PC, and after i selected from the Multi Boot Menu, the usb flash drive with Mint17.2, i saw a black screen(waited about 10 minutes while nothing happened on the screen and then I manually restarted); second I tried was modifying the boot order in BIOS, and selected the usb flash drive as the first in order which gave me the screen with GNU Grub v2.00-7ubuntu11 from which i could select: 'Start Linux Mint 17.2 Cinnamon 64-bit' , 'Start Linux Mint 17.2 Cinnamon 64-bit (Compatibility Mode)' and 'Check the integrity of the medium'. After pressing the first 2 options, the computer simply restarted immediately and i arrived at the same grub screen.

P.S. Success with unetbootin! After the failures above I repeted step 1, and at the step 2, I used unetbootin-linux-608 on the same usb flash drive. At step 3 both Gparted and fdisk reported everything normal(both partition table(msdos) and filesystem(fat32) were the same as before writing to the flash drive). At step 4, it did boot from the flash drive but directly into GRUB 2 command shell(but right before the grub I could see a line for 1 second saying "Secure Boot Not Enabled"). Then at the prompt grub> I typed exit, and after pressing Enter, it finally gave me the Unetbootin menu from which it succesully loaded Mint 17.2 but only when selecting "Start Linux Mint".

ask666 9 years ago

thanks so much , but i use universalbootin of a console on win7 machine. I started with a usb key Sandisk with 4 GB of space. I started win universalbootin and a 2 GB of Mint Cinnamon ISO 64 Bit downloaded from linuxdistro site. The procedure start at 14.20 and at 14.23 was ended. at 15.00 mu system was installed (with slow speed of usb key, because none drivers was loaded , but everithing was installed, the system was updated an upgraded so finally I added my favourite apps for comuninication ad graphics manipuliation. Nvidia drivers must be updated because a strange flicking appears on my desktop .Before it , i used Ubuntu 9.04 for many years and it run very best for me.. MY machine wal old , Im thinking to buy a multicpu with Xenon and make a big worstation with SAS disk and a SSD for s.o. . Windows was ejected by my workspace, but i must to use it when one of my friends or client need my support. all of them are so ostinate that they used windows.
Thank a lot for all .......

AbeFreeman 9 years ago

THanks so much for this tutorial. I tried to use UnetBootin, with the result that I didn't even get a grub menu when booting that usb stick. ("Hybrid ISOs are still compatible with Unetbootin.." wasn't true for my old Mint10 version of UnetBootin). But the fdisk (should clarify -1[L] not -1[one] so more people don't have the problem PaBlum had) and dd commands worked like a charm.

jimwg 9 years ago

I know this is late for this page but it also involves a wider issue I hope you can expand on in another feature. I have people telling me that the main differences between running a OS like Puppy or Porteus vs Mint on a flash drive is because they cause less "wear and tear" on the flash drive and are supposedly faster. Can you clarify this, and secondly, if partially true, are there any "tricks" to improve Mint on flash drives like assigning its caches to RAM and so forth?

Thanks for any input on this!

Jim in NYC

PaBlum 9 years ago

You're amazing -- or you simply don't live in the same universe as I do.
--Your "fdisk -1" is incomplete. It requires a parameter called , which I can't guess at. It also says -1 is not a valid option entry.
--My 13(MAYA) contains not a trace of "USB Image Writer". Software Manager installed usb-imagewriter but hid it very nicely. I eventually found that the Terminal just calls the program "ImageWriter". Cute!
--My purchased ver.17 OSDisc never heard of your word "linuxmint". I eventually found that the needed word is isolinux.
A transfer from HDD to stick worked enough to clean the stick, but then quit, promising that more error information would be written to my home directory, which it wasn't.
So now I'm having trouble finding where I can buy a Windows-7 installation disk! After ten-plus years of struggling with Linux unprofessionalism I've had enough.
Thanks for six hours of hacking and frustration.

april90 10 years ago

can this step works with, Linux Mint 16 "Petra" - Cinnamon (32-bit)?
4gb flashdrive is enough?

dpa2007 11 years ago

the above procedure is only for creating a bootable usb stick in order to install Linux Mint?is it possible to fully install Linux Mint on a usb stick in replace of of a bootable cd/dvd?

S0ul 11 years ago

screenshot of linux mint 14 cinnamon running on MacBook Air Gen 2

S0ul 11 years ago

I successfully installed linux mint 14 cinnamon on my macbook air gen 2 via a bootable usb stick, here's how to create the boot stick inside mac osx:


cryptic 11 years ago

works well but I'm running Ubuntu 10.04 and i have to run imagewriter as root:
"$ sudo imagewriter"

Hexeta 11 years ago

I'm running Windows Vista and want to create a bootable Live USB of mint 13 for which I've downloaded the ISO file.
I've downloaded "Image Writer" from the link here, but I'm finding it impossible to "Simply run the uitlity" as the readme note says.
Can anyone explain how to use this please?

rjlohman 11 years ago

Thanks. Can't wait to try this to get mint on the netbook.

@Tuber: to be precise, KB, MB, GB, etc. refer to the metric system (base 10) so 1 MB is 1,000,000 bytes. If you wish to represent a number in an abbreviated base 2, use MiB, GiB, TiB, etc.

The convention of using a single char to represent a unit of measure as you correctly demonstrated in the dd command is a convention specific to the developer, not at all tied to the base if the numbering system.


pmorcombe 11 years ago

I have been using that Pendrive Linux tutorial but it drives me crazy because of the lack of "persistence". You appear to have taken care of that problem!

duervo 11 years ago

Here are the steps for Mac OS X (similar to the steps using Terminal):

1. First, I used diskutil to reset the USB key to a single partition.

2. Next, I ran the following commands from a terminal window:

# Become root
$ sudo su

# Lst current drives, to get device name for USB key (in this example, the USB key is /dev/disk1)
sh-3.2# diskutil list
0: GUID_partition_scheme *100.0 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_HFS Macintosh HD 99.7 GB disk0s2
0: FDisk_partition_scheme *4.0 GB disk1
1: DOS_FAT_32 UNTITLED 1 4.0 GB disk1s1

# If the USB key has a partition from it that is currently mounted, then unmount it.
sh-3.2# diskutil unmount /dev/disk1s1
Volume UNTITLED 1 on disk1s1 unmounted

sh-3.2# ls

# Write the Linux Mint ISO image to the USB key.
sh-3.2# dd if=./linuxmint-13-xfce-dvd-64bit.iso of=/dev/disk1 bs=1048576
795+0 records in
795+0 records out
833617920 bytes transferred in 490.581580 secs (1699244 bytes/sec)

Chesterboy 11 years ago

As an update Please note I was referring to the Binary zip version of Image writer 0.6 and running it under Windows xp..... Just download it and unzip then run Select the Linux Mint ISO making sure to rename it to an IMG file. Then select where your USB Drive is and off you go...

Chesterboy 11 years ago

This worked perfect for me using an USB on an old Compaq4000 wunning win xp Do note I used win Image Writer........ But please note when you go to download do use the version 0.6 and make the change from ISO to Img... note the the file name. Also note I'm using Linux Mint 13 iso

Tuber 11 years ago


Isn't bs=1M easier to type? 1024x1024=1048576 bytes, or 1 Megabyte, which can be abbreviated in dd by 1M.

c =1
w =2
b =512
K =1024
M =1024*1024
G =1024*1024*1024
and so on for T, P, E, Z, Y.

breaker 11 years ago

For the command below, label -I, that is dash capital i, not l or 1...

See man mkfs.vfat for the manual page and switch details...

breaker 11 years ago

Good one. For those who need to reformat their drive when done...

For FAT32 from Linux; sudo mkfs.vfat -n label -I /dev/sdx
(label is what label you want to use)

For those in Windows, a fine program to reformat to FAT32 is RMPrepUSB, you can use the "clean" option first if it gives you issues; It is an advanced removable drive prep tool, but also good for formatting.

reesemitchell 12 years ago

this is to mugabuga What it did was creat a partion on your usb key what you need to do is delete the partion and refoment your usb key you can do this by useing gparted if you do not have it install go to the termail and type sudo apt-get install gparted

once it is install just find your usb drive:"WARING" DO NOT DELETE OR FORMAT THE WRONG DRIVE" BECAREFUL.

once you do that it should fix your problem i hope this helps.

if you want your usb compatible with windows use ntfs if you just want it compatible with linux use something like ext

i hope this helps.

reese mitchell.

mugabuga 12 years ago

I used imageWriter and now I can't seem to figure out how to re-format my USB back to 8GB. It's current capacity is reading 1.1GBs. Any way to reformat it to it's correct size?

blu35p4rr0w 12 years ago

Do not listen to the guy below me. Win32-Disk-Imager is less confusing and requires less clicks to use than LinuxLiveUSB. It also doesn't require watching a video to use. Just change the .iso to .img like it says in the tutorial above. Select the USB drive you want to use and the .iso you just renamed to .img and click write. There is no "What the heck is persistent mode? What are the checkboxes in Options for?" Win32DI is just click, click, click, done.

If you use Win32-Disk-Imager it will change the USB drives capacity to that of the .iso you wrote to it. Windows will not recognize it's full capacity in order to format it properly. If you want to fix this in windows you can use a program called "Bootice"

How to:
Download Bootice 0.9 from the address below.
Extract bootice_0.9.rar
Select the USB you want to restore under "Destination Disk"
Click on "Parts Manage"
Click on "ReFormat USB disk"
Leave "USB-FDD mode" checked and click on "Next"
Select "FAT32" and give it a label if you wish then click "OK"
Click "Yes" to confirm and voila
Now your USB has a new MBR and its full capacity is restored!

The Tutorial above covers everything you need to do in order to get a fully working bootable LiveUSB for LinuxMint12. Don't waste your time with LinuxLiveUSB if you're doing this in windows. I will note that whilst the terminal command did create a LiveUSB, my bios would not boot it since the USB wasn't FAT32. Also, I could not figure out how to use ImageWriter or StartupDiskCreator in Lighthouse64 which is not based on Debian at all. I'm a noob when it comes to compiling source code, nor am I familiar with the terminal commands Lighthouse64 uses. So Win32-Disk-Imager on my Win7 laptop was my best choice.

kittyspit 12 years ago

For a nube, all these options were non-intuitive and missing instruction. However, I found a really great install program called "linux live usb creator." Here's the youtube video and the link for download is there. Totally foolproof.

matheos 12 years ago

Cool !! very nice this tutorial but how to go back to normal partiton now ?

we must delete partition table, rewrite it and format it in fat32.

yurayko 12 years ago

'oflag=direct' explained above: "you can just leave it out as it is simply intended to speed up the process a bit" ie avoiding the buffer cache, and 'bs=1048576' equal to the 'bs=1k' it means block(s) is/are 1MB

Polo 12 years ago

I'm very new to this, but I used "Startup Disk Creator" (installed with Linux Mint 12) to transfer the .iso of Mint LXDE to a USB flash drive, as I wasn't getting much joy with the method described above.

The drive appears to be persistent (although I may well be failing to understand what persistence is, of course) - in fact part of the process, the GUI states that it's creating persistence files (or something similar, this is from memory).

LXDE runs perfectly - with the small exception of my eee PC 901 needing the Esc key pressing on startup to force it to select the USB to boot from. This may also be the reason why the method on this page didn't work...

clem 12 years ago

Thanks, typo fixed.

danpe91 12 years ago

What is this for?

" oflag=direct bs=1048576 "

Rua42 12 years ago

I think there is a small mistake? In the first command line in the tutorial, 'bs=' is missing?

mattzyzy 12 years ago

Just my two cents, for other Mint flavours-Main/Gnome v12 v11 v7-v10 (of course dozens of other Linux distros -even FreeDOS,Parted Magic , etc) standard ISO image file (.iso) ,not hybrid which is not covered by above tutorial, you can always use free open source UNetbootin .

UNetbootin -easy to use ,small file-intuitive user interface,(Windows,Linux and Mac OS X) and simplistic online documentation (one-page user guide+FAQs) .GNU GPL v.2

Just make sure the USB stick/pendrive/thumbdrive is formatted with FAT32 filesystem and enough space allocated.

UNetbootin can also help you download the ISO (If you haven't downloaded it yet) . It even allows for internal hard drive setup( a bit complex though for hd that already have operating system installed).

Hope this helps.

**Oh , fyi,this comment is written on Linux Mint 12 32-bit Gnome Lisa(live) on my 2-year old 4gb usb2.0 stick created using UNetbootin

eklem 12 years ago

Just to help those along that have the same question as I: Where to find the hybrid image? Go to "Download > All versions" and click on "12" or "Lisa". At the bottom you find the KDE RC-versions (32 and 64 bits).

Or simply go to this link =)

And a small error possibly (not sure, since it's Mint-syntax):
apt install usb-imagewriter
should be:
sudo apt-get install usb-imagewriter