They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
slackjp
Score: 0
votes: 8
Format: Article

 Evolution crashes when saving or editing a Contact [Solved]: Search and Delete Duplicates !


Several late versions of  Evolution Groupware suite suffer from this annoying problem (It seems to be an old bug, but I have noticed with versions 3.x, up to version 3.2.2 (as March 2012).

Problem: Evolution crashes (and closes unexpectely) when saving a contact that you have been updating.

Origin: It happens if you modify or add an e-mail address to a contact that is, in fact, duplicated. The duplicated e-mail is a trigger of this bug.

It happens after sending an e-mail to an known person but with an e-mail address new to Evolution-Contacts. This new address is automatically added to Contacts as a new contact with the e-mail address as the name of the contact. If you later try to modify/correct the original contact with the new address (additional) you will be unable to do so.

An e-mail address cannot be repeated in any other person record (wife/husband/friend/work/...). If an address appears in more than one single record, pe.: as an altenate e-mail address Evolution will crash. If you need this info for your reference: add the e-mail address in Notes.

Solution:  [Solved] Just search and delete the duplicate contact (p.e. can be unnoticed, just sharing the same new e-mail address being added), and then complete the edition of remaining contact as required with the new or additional data/fields.

Step by Step:

  1. Search for duplicates of the contact bearing problems by name and/or by e-mail. You will find several duplicates or contacts sharing the new e-mail that you were trying to add.
  2. Save the relevant information. Before deleting anything copy and save the relevant information elsewhere.
  3. Delete duplicated contacts as required. One or many.
  4. Edit, type or copy the new information in the remaining contact.
  5. Save and done !

References

These were reports of bugs that pointed but didn't solved the problem : https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/912081   - https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/879367


Tags: Evolution v.3.x Crash saving Contact duplicated solved
Created: 5 years ago.
Last edited: 4 years ago.
Reviewed: 5 years ago.
Read 0 times.

Comments

No comments so far.

Other tutorials from slackjp