They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
Alexio
Score: 32
votes: 44
Format: Article

 Reset forgotten/lost main user password in Linux Mint


You can reset your password following the next steps:

  1. Reboot your computer / Turn your computer on.
  2. Hold down the Shift key at the start of the boot process to enable the GNU GRUB boot menu (if it does not show)
  3. Press ESC at the GNU GRUB prompt.
  4. Press e for edit.
  5. Use the Arrow keys to highlight the line that begins with kernel and press the e key.
  6. Go to the very end of the line and add rw init=/bin/bash
  7. Press Enter and then press b to boot your system.
  8. Your system will boot up to a passwordless root shell.
  9. Type in passwd yourusername
  10. Set your new password.
  11. Restart your system.

Tags: reset user password
Created: 3 years ago.
Last edited: 3 years ago.
Reviewed: 3 years ago.
Read 3122 times.

Comments
4 months ago

w5gcx
GNU GRUB file does not have line with kernel  
8 months ago

jamint
merci alexio et eiger3970

en francais
1) demarrer l'ordi en appuyant sur Shift jusqu'à apparition d'un ecran avec 3 ou 4 lignes.
2) taper la lettre e
3) il y a une dizaine de lignes d'écriture qui vont s'afficher; sur une ligne vers la fin c'est écrit ro quiet ... handoff; vous effacer la fin de la ligne à partir de ro et à la place de ro quiet ... handoff vous ecrivez rw init=/bin/bash
4)vous sortez de cet ecran en appuyant les touches Ctrl+X
5) plusieurs lignes vont defiler et quand ca s'arrete vous tapez : passwd "nom"(vous remplacez "nom" par votre nom vraiment que vous avez rentre lors de l'installation)
6) la machine vous invite à rentrer un nouveau mot de passe
7) quand c'est fini faites Ctrl+Alt+Suppr pour sortir
relancer votre ordi
 
10 months ago

norm37
My password was not forgotten, but another had been introduced by Mint. This procedure should cure the problem.  
10 months ago

jahid_0903014
great!  
1 year ago

sp5bud
Thanks eiger3970!

'rw init=/bin/bash' works in my Linux Mint 14 (Nadia).
Have a nice day!

Kris
sp5bud
 
1 year ago

carlos-teran
It's really a life saver. It's a little bit dated, but thanks to the helpful comments from eiger3970 and vonoctra, it still has relevance. Thank you for sharing and saving the day.  
1 year ago

Loreina
This works in Mint 14 (Nadia) but it doesn't reboot to a screen, which is what us newbies look for. When the program gets to the end of its reboot run, where it says 'no job control in this shell', don't worry about that. Continue on to step 9, as Alexio says. It will work. Also, holding down shift in Nadia didn't give me the GRUB menu automatically. It gave me the F2 or F12 options. Instead of these hit the ESC key. That gave me the GRUB menu. And it is the line that begins with 'linux' that you have to edit, but there is no highlighting involved. Just change the ro part as pointed out in previous posts. Thanks everyone!  
1 year ago

rhansen
Thanks! I had installed Mint to give it a try and then put it aside for a few weeks so in addition to forgetting my password, I also forgot my username. After getting to the BASH prompt, I typed 'cat /etc/passwd' and looked at the bottom of the list to find the username I had chosen, so now I am back in again!  
1 year ago

blumhoefer1946
JUST INSTALLED Linux MINT AND BOOTED UP AND IT ASKS FOR USER NAME AND PASSWORD????
Where/when was I supposed to enter them, prior to this??
 
1 year ago

eiger3970
I tried this on my Linux Mint 12, however it it doesn't work.
Boots into a black screen and have to manually reboot and then shows regular welcome screen.

I tried:
In Linux Mint 12, the line to edit begins with "linux" and not "kernel"

Follow steps 1 through 4 above.
In step 5, navigate to the end of this line:

linux /boot/vmlinuz-3.0.0-12-generic root=UUID=[letters and numbers]\[letters and numbers] ro quiet splash vt.handoff=7

replace

ro quiet splash vt.handoff=7

with

rw init=/bin/bash

so it looks like this:

linux /boot/vmlinuz-3.0.0-12-generic root=UUID=[letters and numbers]\[letters and numbers] rw init=/bin/bash

Press Ctrl-x or F10 to boot with these options
Follow steps 8 through 11 in Alexio's tutorial as normal
 
1 year ago

vonoctra
Thank you to Alexio and bugmenot. Extremely helpful. I am no guru, but if anyone does have results, this is what did:
1) start computer, press f10 to launch the boot screen. (I use multiple operating systems so there were many options)
2) Using the arrow keys, I moved to Linux mint (not Linux mint in recovery mode) and hit "e".
3)again using the arrow keys, i moved down to the line beginning with linux/boot etc.. etc.. (as posted by bugmenot)
4)using the arrow keys I started replacing the command as directed. NOTE: THE RW HAD TO HAVE THREE SPACES AFTER IT BEFORE TYPING INIT=/BIN/BASH example: rw>>>init=/bin/bash NOT rw>init=/bin/bash (> being a space)
5) after replacing the command I used the arrow keys and moved up to the very top line then hit Ctrl+x. I dont know why but that is how it worked for me.

Also, if anyone is new to this like me, this might help. Step 9 is type "passwd yourusername". if your username is john you would type "passwd john"
the system will then request a new password. when entered my new password the characters were not visible, and the cursor did not move. BUT IT DID WORK.
Thanks again
 
1 year ago

uzbad
Well, dunno about how to get GRUB in Mint 14 menu as I had it from beginning, but to get things going I edited the rescue mode by replacing everything in the line starting from ro to the very end of it with init=/bin/bash, then pressing F10. This worked for me.  
1 year ago

iamclam
I want to try this on my Linux Mint 14 but for some reason it wont go to the GRUB menu when I boot holding shift. I hold shift, turn it on, keep holding shift, and it just boots right up to the desktop.  
1 year ago

josefg
Excellent! Worked on Linux Mint 13.  
1 year ago

arafs
how about linux mint 14? does it work?  
1 year ago

kentmint
I think you should update the article according to bugmenot's comment. As of Linux Mint 14 RC (Nadia), bugmenot's comment is correct.
Thank you, Alexio and bugmenot.
 
2 years ago

Marcy
What about Linux 9? Am a TOTAL Linux (but not computer) newb.
Installed Linux (Isadora, it says) on HP Omnibook 6000.
Made it as simple as possible: I know my user name, I know my password.
I enter them in their boxes as they appear/are requested
(first one, then the other, but both never appear on the same screen. Also tried UC and LC letters, or first letter UC)
Box(es) return(s) for me to fill again -and again - and again - and again..... (ad nauseum) :x
NOTHING else happens, not even an error msg. :?: :?: :?:
Have rebooted -several times.
Have reinstalled and rebooted.
Same result. :evil:

Attempted the fix but got same result as djbyardie.

Ready to go back to Ubuntu, no matter how slow it was (and will be again) because at least it WORKED and made sense!
Would be a shame to quit now, but this...is...bloody...annoying :!: :!: :!:
The only good news is that this is a new install and I have nothing to lose, except time and my temper.
Help!
 
2 years ago

Gutknecht
Did not work on Linux Mint 13 even with @bugmenot clarification. Hit Ctrl=X or F10 screen went blank and nothing...... I see a reinstall in my future. But it shows me how much more secure Linux is....  
2 years ago

Alexio
@stefi - You are welcome!  
2 years ago

stefi
Thank you so much! Months ago i wanted to change my password, meanwhile anything happend and i went back from my netbook.... and was only able to log into my sons account whithout any permissions.

THANKS for bringing the files into my life again!!
 
2 years ago

djbyardie
Could not get it to work.After Step 7 did its thing for a while then came up with the following: bash:cannot set terminal process group(-1)Inappropriate ioctl for device.
bash:no job control in this shell
Any further help would be appreciated as i am new to Linux
 
2 years ago

kencameron
I made it up to step 9 (using bugmenot's variation) with everything looking ok, but then couldn't proceed - didn't know and couldn't work out how to set a new password or to restart my system. I am an absolute beginner with linux. Any further help would be much appreciated. My situation is that I can log on without a password but then am asked for a keyring password, which I put in successfully, but when I try to install apps putting in what I think is the correct password (the keyring password is the only one I have ever used on the system) I get "sorry...".  
2 years ago

Alexio
@bugmenot & @compuman2004 - You are welcome!  
2 years ago

mcfaiaz55
It does not work.  
2 years ago

Tazmanian-Hat
Thanks for this. but I can't get past step 3. It won't respond to anything at the GNU GRUB screen.  
2 years ago

cutabovehost
There is no line that begins with kernel as described in step 5  

Other tutorials from Alexio