HP Linux Printing and Imaging System (HPLIP)
  20 reviews

The HP Linux Printing and Imaging System provides full support for printing on most HP SFP (single function peripheral) inkjets and many LaserJets, and for scanning, sending faxes and for photo-card access on most HP MFP (multi-function peripheral) printers.

HPLIP is composed of: * System services to handle communications with the printers * HP CUPS backend driver (hp:) with bi-directional communication with HP printers (provides printer status feedback to CUPS and enhanced HPIJS functionality such as 4-side full-bleed printing support) * HP CUPS backend driver for sending faxes (hpfax:) * hpcups CUPS Raster driver to turn rasterized input from the CUPS filter chain into the printer's native format (PCL, LIDIL, ...). (hpcups is shipped in a separate package) * HPIJS Ghostscript IJS driver to rasterize output from PostScript(tm) files or from any other input format supported by Ghostscript, and also for PostScript(tm) to fax conversion support (HPIJS is shipped in a separate package) * Command line utilities to perform printer maintenance, such as ink-level monitoring or pen cleaning and calibration * GUI and command line utility to download data from the photo card interfaces in MFP devices * GUI and command line utilities to interface with the fax functions * A GUI toolbox to access all these functions in a friendly way * HPAIO SANE backend (hpaio) for flatbed and Automatic Document Feeder (ADF) scanning using MFP devices

USB and JetDirect (network) devices are supported.
Latest reviews
elisabo 4 months ago

Worked great on 20.2. Now, it's a real mess under 21. The gui doesn't even show up after installing it. New version online hplip-3.22.10.run: doesn't even want to install. I have an HP All-in-one 3630. What a mess...

joelb 7 months ago

Some HP printers require the installation of a plugin to get everything working. My LaserJet Pro MFP M281cdw printer was automatically recognized but the scanner was not, until I installed the plugin. To install the plugin, open a terminal and enter "sudo hp-plugin".

yamahacrazy 8 months ago

this is an outdated version. there's a new one available via HP website 3.22.4 i've always had better luck with the linux version of this software than using the windows version. quite sad the windows version always has communication issues with the printer. the linux team is much better at their job

ghost123uk 1 year ago

Re Linux versions 20 and up = Edited my negative review because I sussed it out. You simply *don't need* this AND if you (try to) install it on versions 20 and up, it messes things up!! In the end I did a re-install of Mint20.03, did *not* install this, and my HP Deskjet 26000 just "plugged and played", scanner just fine also.

Kraiye 1 year ago

Nothing works in Mint 20! Software Manager version outdated, auto install version fails to find pyqt5, manual version fails at "make" - nothing happens, no make file (although I think is due to incomplete instructions).

linuxmintforum 2 years ago

hp-install solved missing plugins hp- tab tab gives interesting options

mime 2 years ago

For Linux Mint 20: Get Version 3.20.9 via HP Supportpage or Sourceforge and install manually after deinstalling this version (important). It does then what it is supposed to do. I use it for controlling my HP OfficeJet Pro 8720 with a lot of features like ADF, duplex printing and so on. Everything works fine, printer and scanner and even fax would still be available (but who needs it ?)

oldtimer 2 years ago

all, Info from the HPLIP release notes may help with what version to install for your Linux Mint Distro: LM20 - 3.20.9 [released early Oct-20], LM19.3 - 3.20.3, LM19.2 - 3.19.8, LM19.1 - 3.19.3, LM19 - 3.18.9. For those on LM20, it is complicated by the fact that there is a regression issue in Linux Mint 20. Apparently, some USB printers & scanners which worked perfectly fine in 19.3 no longer work in 20. See Clem's 'September 2020 News' in the Linux Mint Blog for more details & potential workaround. May have to wait until 20.1 release in Dec 2020 for a stable solution.

kassuncao 2 years ago

Não funciona no Mint 20

m3rc 2 years ago

I have been unable to get past the hplip firewall/permission error with 3.20.3. After reviewing the comments on the sourceforge site. I downloaded 3.18.7 and now my m175nw works great with mint 19.2. It warns you that you're installing a version that was for 18.3, but install anyways.

aedoue 3 years ago

Default version didn't work with mint 19.1, but latest version from sourceforge prints.

bLuegLue6705 4 years ago

Works good

joseluis 5 years ago

doesn't work for Mint 18.3. I've had to install the hplip from https://sourceforge.net/projects/hplip/?source=typ_redirect and compile in my Linux Box

drewt333 5 years ago

Useless. No support for Mint 17.3

BernieLJ77 5 years ago

can't scan with my HP Officejet 6962 using Simple Scan...Wonder if there's some other program I can use to scan with?

cryssti 7 years ago

Foarte util pentru imprimantele hp. Atentie la versiunea folositsa de hplip si versiunea sistemului. Cu 17.2 e posibil sa nu functioneze prea bine.

pollat 7 years ago

Had to install it from a site (thanks elstellino), because 17.2 bundled version did not work for my scanner. Now working ok, although shown as not installed in software manager.

Joe76000 7 years ago

I'am using Rafaela (after Rebecca) Cinnamon both 64-bit. Same HPLIP issue with both distros even using the latest HPLIP 3.15.6. Everything is working well with my HP AIO Pro 8610. The problem is HPLIP Satus Service is not working at all even disapearing. On the same HP laptop, Ubuntu 14.04.x doesn't have this issue. Would be nice that Linux Mint developpers could fix it. Thanks.

warlock3 7 years ago

Easy to use

penttila 7 years ago

I successfully upgraded from LM Cinnamon 17.1 to 17.2. Unfortunately printing with hplip does not work any-more. Hplip asks me to 'Install Required Plugin', but the process fails. When installing the plug-in from an HP-authorised server the following error occures: /home/andras/.hplip/hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered