They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
tpapastylianou
Score: 13
votes: 18
Format: Article

 Fully graphical boot (Mac / OSX style) using grub2 and burg-manager. A step-by-step guide.


 

----------------

*** UPDATE ***: Apparently Burg Manager has been superceded by Super-Boot-Manager which potentially makes the instructions below somewhat useless. Please have a look at the comments below for links

----------------

 

I'm putting this tutorial up, as promised here: http://community.linuxmint.com/idea/view/215

This is a step-by-step guide on how to set up a nice graphical boot screen, similar to Mac OSX bootcamp, using a package called burg-manager (many thanks to Tracerneo for pointing this out in the thread).

Here's my own boot screen (click image for higher-res), just http://img214.imageshack.us/img214/7702/mintburg.pngto give you an idea of what to expect. You can choose from a variety of themes, and you'll be happy to know that you can swap between themes at boot time, rather than via configuration files :)

There are five steps in this guide:

  1. Configure grub2 via startupmanager
  2. Install BUC (burg-manager depends on this package)
  3. Install burg-manager
  4. Use it to install burg as your default bootloader
  5. Tweak the configuration files for 100% shininess :)

There's  also instructions on how to uninstall, if you need to, at the end of this tutorial.

-----

Step 1. Configure grub2 via startupmanager.

Startup-Manager settings for a fully graphical boot in grub2-wiseIf you feel your boot sequence, as far as grub2 is concerned, is actually working fine, then skip this step. I had to tweak things a bit because I was getting this problem (which is one of the known problems we're warned about at the linux mint welcome screen). Incidentally, I only get this after I install my nvidia drivers, so you may not have gotten this problem at all, or may have had other problems. Either way, follow the instructions on that page, and play around with startupmanager until you're happy with your grub2 settings. Don't worry about background images at this point, as these won't be used by burg (you can add your own background picture using custom burg themes, which I'll mention later on).

As I wanted a fully graphical boot sequence, I chose the following settings, as they appear in the picture to the right (click for higher-res image), i.e. a boot splash (the 'Linux Mint - from freedom came elegance' graphical logo), suppressed verbose output, and a decent resolution.

-----

Step 2. Install 'Basta-Un-Click' (BUC).

We're now pretty much following the flow of the original article for installing burg-manager. You can either install BUC by downloading the deb package from this page and installing it using gdebi-gtk, or by using the repository method (the link has been 'google-translated' from italian for your convenience :) ). I chose the repository method, since there might be updates at some point I might benefit (or suffer) from. Ignore the "Vai alla cartella" notice you get btw, it's just a 'do you want to read the README file' thing. Click on it then, close it and proceed.

-----

Step 3. Install burg-manager

Again, follow the instructions in the sourceslist.eu website to install burg-manager either as a .deb file, or using a repository. I chose the repository. During installation you will be asked about grub2 settings, just choose the default settings everywhere (i.e. press enter)

(Note: One of the settings is which harddisk the bootloader will be written to. I'm assuming this will find the right one from grub, but it's worth keeping an eye for it. If it's wrong, use space to 'tick' the right one, before pressing enter. I only have one harddisk so there wasn't a choice issue for me here, but I thought I'd mention this just in case.)

-----

Step 4. Install burg as your bootloader

Burg-manager should now be on your MintMenu. Find it under 'System Tools -> Burg-manager' (or just run burg-manager from a console). Don't be alarmed if it's taking a while to show up; it needs to 'call home' first to do its business, which sometimes takes a while. In the opening screen click on burg-install. Make sure you choose the right hard-disk! (I only have the one so it wasn't an issue for me).

Apparently the developers predict that kernel/grub updates will probably mess things up. Whenever your update manager downloads a kernel update (you'll know because it will ask you to restart), come here and click on Restore Burg into MBR to reactivate the shiny graphical booting :)

-----

Step 5. Adjust settings and tweak the configuration files

First, click on the 'Themes Installer' tab and install any themes you like by double-clicking on them.

Then click on the 'Parameters' tab. If you're unlucky like I was, the 'Set Screen Resolution' menu (under the 'Basic Parameters' tab) will not have a suitable resolution for you to choose from. Don't worry about that, we'll tweak the configuration file manually in a minute. Set the timeout you want and click apply. You might also want to execute the 'Remove previous kernel versions' option, otherwise you may end up with multiple linux mint icons on your boot menu.

I'm guessing that when there's a kernel update, you'd also need to come here and execute this again, (as well as restoring burg to the MBR, as mentioned above), since kernel updates usually add more boot options to your list.

Now comes the tweaking part. Go to the 'Advanced Parameters' tab, and click the 'Open file' button on the top, to edit the /etc/default/burg file as root. If you want you can edit this without using burg-manager, but you'd need to run 'sudo update-burg' after you save it, to apply the changes -- burg-manager does this automatically for you as soon as you close the text editor it opened up for you (you still need to save the changes you made to the configuration file by manually clicking 'save' though)

Lines beginning with '#' are comments. Other lines represent commands. First thing you may note is that a lot of the comments talk about 'uncommenting the line below it.' However, if you clicked on the buttons in the basic parameters previously, it may have moved some of these commands at the end of the file, away from their comments. Don't worry about that. There are two important lines we need to change.

The first is this line:

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# In the boot menu, use hotkey 'r' to popup a resolution selection menu.
GRUB_GFXMODE=default

and change it to

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# In the boot menu, use hotkey 'r' to popup a resolution selection menu.
GRUB_GFXMODE=1024x768

This determines the resolution of the initial boot screen you see. It's not that crucial, as I think you can choose a different resolution at boot time by pressing 'r'. The important thing is that it's not a resolution that will not be supported by your monitor in basic (i.e. not hardware accelerated) mode.

 

The second step is adding this line at the end of the file:

GRUB_GFXPAYLOAD_LINUX=1024x768

This tells burg to continue at a resolution of 1024x768, which is necessary to get our nice little 'Linux Mint: from freedom came elegance' logo properly. If you don't add this, expect the non-graphical version.

Save the file and close it.

Note you don't then have to press 'Apply' in the 'Parameters' tab again, the configuration is now usable. In fact, pressing 'Apply' will overwrite any changes you've made in the file with settings that are present in the 'Parameters' form. (Thanks to goly for pointing this out)

If you now go back to the main 'Burg-Installer' screen, you can press on the 'burg-emu' key to see how your boot screen will look like. You can try out new themes by pressing 'T' (you can also do this at boot time).

Note that 'r' doesn't work in emulation mode, but at boot time, pressing 'r' will enable you to swap between available resolutions. You can press 'h' or F1 for some more commands.

-----

Uninstalling burg and reinstating grub2

Burg-manager has a tab called 'Remove Burg'. I tried this, but for some reason it did not revert to my earlier grub settings very well. Instead it gave me a white-on-black monochrome textbox with no background image, i.e. the most basic grub menu possible. If you get the same problem, you can fix it by manually running

sudo grub-install /dev/XXX

at a terminal, substituting XXX for the harddrive you boot from (mine was sda, which is the only harddisk I have). This brought me back to my good old hi-res grub2 boot screen with the linuxmint.png background image.

-----

That's it!  Have fun! If you want to hack around with the themes and mess around with the backgrounds or icons the themes use, look in /boot/burg/themes. The configuration files aren't too hard to follow.

 

PS. As an afterthought, if your motivation in wanting a fully graphical bootloader was to get as 'Mac OSX' like as possible, then you might also want to check out macbuntu. Though personally, I think the standard Linux Mint 10 desktop is 10 times more gorgeous, elegant, and functional than any of its 'competitors' :)


Tags: boot, grub, grub2, burg, burg-manager, Mac, OSX, Apple, graphical, startupmanager
Created: 8 years ago.
Last edited: 7 years ago.
Reviewed: 7 years ago.


Comments
7 years ago

tpapastylianou
thanks for the update bobbomo  
7 years ago

bobbomo
@tpapastylianou, thanks for the write up!

FYI: Burg-manager has been super-ceded by Super-Boot-Manager.

sudo add-apt-repository ppa:ingalex/super-boot-manager
sudo apt-get update
sudo apt-get install super-boot-manager

http://www.sourceslist.eu/blog/linux-blog/super-boot-manager-buc-version-download-installation/
 
8 years ago

goly
Ok I got it. Thanks again :D

@luisnando: as I have installed everything, I have also somehow mixed up step 2, 3 and 4, because of the jump from the BURG installation windows and the browser to follow the guide. There are 3 things to do:
1- Install the application "BUC"
2- Install the application "Burg-manager"
3- Open Burg-manager and click on "burg-install". This will let BURG to start at the boot at the place of the grub interface (be careful to choose the right partition!).

During the last step I was faced with a problem with the repositories and the installation did not complete. In this case you don't get any error message! Only if the installation completes successfully you get a window message.

In my case the problem was the wrong authentication of dropbox repositories. If you don't have any problem with your repositories you shouldn't either have any problem with BURG installation.

Greetings
 
8 years ago

tpapastylianou
@luisnando: Re-read Step 4 carefully, I think you may have skipped the 'burg-install' step.

@goly: I'm so sorry, I skimmed through your post the first time, I didn't realise you were talking about /boot/burg/burg.cfg as opposed to /etc/default/burg. In retrospect what you said makes a lot more sense, as there's nowhere to edit titles in /etc/default/burg :p

Right, the trick is this: If you try to edit /boot/burg/burg.cfg, you'll notice on the top of the file that it says "Do not edit this file, it is generated automatically". This means the file is updated everytime the command 'update-burg' is issued, whether directly by yourself in a root terminal, or indirectly by burg-manager. Therefore, yes, what you described is expected behaviour. To modify the names, you can edit the /boot/burg/burg.cfg file without running update-burg (or without making any other changes in burg-manager that would result in updating the burg.cfg file). Try it; modify the burg.cfg file by hand and you should see the changes immediately in burg-manager's emulation (simply running burg-manager won't cause an update). I think after you've modified that cfg file the modified names will be appear in burg-manager options anyway. As long as you don't click on 'Apply Changes' below, as that runs 'update-burg' which will rewrite the names with the default values (i.e. the '2.6.35-22-generic' stuff found elsewhere in your system).

Here's an example of when I did it with the mint theme: http://goo.gl/WXrHx

As for the mint theme question, yes, I tried it just now and it does seem slightly slower than compared to the emulator ... I think it's just a matter of redrawing the images on screen being a bit slower in the abscence of a Window Manager that takes advantage of your graphics card's hardware acceleration. Or maybe there's a lot of information to redraw compared to other themes. Oh well.
 
8 years ago

goly
Thanks for the fast reply. I solved the problem following your suggestion and clicking on "Apply". Did you try the Mint theme? It is very nice but the icons appear slowly at boot, at least slower than the burg-emu. Please, let me know if you have also experienced the same problem.

Bye
 
8 years ago

luisnando
Actually I think it asks for a installation of Burg. Without that burg-manager don`t properly work. Are there any .deb packages which i could install???  
8 years ago

tpapastylianou
luisnando: There's absolutely no reason why the above wouldn't work for Debian Edition.
(Step 1 is optional, and in retrospect not particularly necessary other than having a nice grub manager to return to in case you decide to uninstall burg, and grub wasn't working properly to begin with, but otherwise don't worry too much about Step 1 if you don't like startupmanager.)
 
8 years ago

luisnando
Can someone port these instructions for LMDE? I would really like this on my rolling distro. Thanks.  
8 years ago

tpapastylianou
You're right goly, thanks for noticing that. I noticed it myself a couple of days ago, but forgot to edit this tutorial.

Turns out the 'gfxterm' line isn't necessary. I've tried it a second time round and it makes no difference, plus it gives that brief yet unsightly error message. So just leave the line as it was before (i.e. commented). I noticed it sometimes takes a 2nd boot to get things working ... maybe that's what threw me off ...

I'll edit the tutorial to remove the 'gfxterm' bit.

As for your 2nd point, yes you don't have to hit 'Apply'. When you close the file, that automatically saves the changes (if opened through burg-manager), and that's a usable configuration by the boot manager. You don't have to hit 'Apply' again. In fact, if you do hit 'Apply' you are changing it *again* to whatever information was contained in the 'Parameters' form (in your case, I'm assuming it's the full name, and you're changing it back to that by pressing the button). So just edit the file, close it, don't hit apply. Either exit, or go to the main screen to confirm it works as you want it to by doing an emulation.
 
8 years ago

goly
Very nice tutorial and funny application. I had only some issues (easily solved) with the repositories installing brug.
I want to ask you about two minor problems which are still present:

1) Right after the boot, "GRUB loading" appears and it is followed by two very fast error messages: "Unknown terminal" and "Unknown... (I couldn't read it)". Nevertheless, the graphical interface works properly afterwards. Do you know a possible reason why they show up and the related solution?

2) I have changed the file "/boot/burg/burg.cfg" to shorten the name of the systems showed at boot by BRUG (for instance: menuentry '2.6.35-22-generic'....). The problem is that the original system names are restored as soon as I select "Apply" in the "Parameter" section of the BURG manager. Am I changing the wrong file or this is an expected behavior?

Thanks in advance
 

Other tutorials from tpapastylianou