They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
slackjp
Score: 18
votes: 20
Format: Article

 Fixing the black screen after grub boot-up (screen/video settings mismatch)


Problem: You got a black screen in place of the friendly graphical login screen at the end of the Linux Mint boot sequence.

Display misbehaving presentation includes:

  1. Blincking cursor at top-left corner
  2. Centered garbled lines of colorful squares
  3. A plain black screen (but this may be related to other issues)
  4. A kind but sticky message that X11 has re-started n times in n minutes
  5. The Linux Mint rotating 'in process' icon

Don't tell me why but I have found this issue in several installations or reinstallations of Linux Mint (and other distributions) in previously working systems. It is related to failed detection of hardware, or by upgraded drivers (nouveau, spring 2011). Current video cards are willing to generate resolutions/frequencies over your monitor's capabilites.

You will end your first install (and/or reboot procedure), with a black screen after several normal messages or disk activity just before getting the normal user prompt  (it will never come out).

It may even happen with the installation CD/DVD of some new distributions (Mint Mate 16, 17)

You will notice that the computer is working fine as it reboots gracefully if you click [Ctrl]+[Alt]+[Del] meaning that you have a working system but with a video problem. It mimicks a computer hanged (dead) but is not the case !

If the monitor is smart enough it will complain about wrong frequency or no signal. 

Here is a simple and short fix that will allow to boot and configure the system from a graphical user interface (In Linux Mint will be Gnome).

  1. Reboot and wait to see the initial boot screen of GRUB with a list of operating systems. Tap a cursor key to avoid automatic boot.
  2. Select your choice (pe. LInux Mint) with the cursor and then press the [tab] key to get the full boot grub commad line. Don't be afraid: is a long command. Avoid modifying it.
  3. Go to the line starting with the word linux and ending with the words: quiet splash
  4. Add one of the following '????.modeset=0' parameter at the end of the long grub command line as is (type 1 space before). Use the parameter related to the brand or chipset of your video card . pe.: use nouveau  or nvidia for nvidia based cards (proprietary driver, just nv in some linux distributions, nouveau driver is the default in Mint) ), use radeon for amd/ati cards, i915 for intel based motherboards, ,,,  These are the most common examples.
    1. nvidia.modeset=0
    2. nouveau.modeset=0
    3. radeon.modeset=0
    4. i915.modeset=0 
    5. r128.modeset=0  (for very old ati rage 128 cards...)
    6. If you don't know the brand you may use just one word:   nomodeset
    7. Your will find the full range of drivers and more info at Xorg.org wiki
  5. Press [Ctrl]+[X] to boot with this added parameter. This parameter will not be saved, just used in this single boot and nothing is damaged. To cancel without changes press [Esc].
  6. Hopefully, the system will boot into a default graphical environment and you will be able to install/reinstall driver or configuration packages. In my case I solved my issues in a old nvidia cards (Quadro NVS 280 and geforce 7300LE) using a legacy nvidia 96 or 173 drivers, respectively, in place of nouveau. And nvidia-settings package.
  7. Desperate Mode. If you cannot get a graphical user interface with this parameter and/or an 'Monitor frequency error'  there is an alternate way (as always in linux). This situation may happen if you have replaced your video card, or the the driver needs additional parameters (I suffered it with a intel chipset)
    1. Use a lower resolution but highly compatible vesa driver. In the same line described in step 3 add this second video mode parameter (grub_gfxmode=). You may use one of them
      • grub_gfxmode=1280x1024x24      (in most large modern monitors) 
      • grub_gfxmode=1024x768x16        (1024x768 is safer in older or smaller systems)
      • Many other settings are possible as: grub_gfxmode=vesa  (...or vga)
  8. For those brave enough, more detailed help may be found at Grub2 help in Ubuntu

(Solved) Update 2014: My Mint Mate LTS 17.0 re-install (Nvidia Quadro FX1400 dual monitor 19'' 1280x1024x24)

  1. Let any Linux distribution 'mature': I waited 1 month before installing this new Mint version. Mate is just for me, and I will try to stick to this LTS. Live is too short to re-install too many times.
  2. Black screen or color squares in the first boot after install. Only able to run a 'text' login with nomodeset. Many restarts tried, but Nouveau was taking control over display even after blacklisting it in /etc/modprobe.d/blacklist.conf: Ough!
  3. Solution as in this tutorial:
  4. While system booting menu (Grub) type e to edit the first grub line (Linux Mint ...)
  5. add to the linux parameters line 2 flags:  nomodeset  grub_gfxmode=1280x1024x24
  6. You will boot with a Linux command line. Don't be annoyed by error screens. Keep calm.
  7. Just in case (Linux is still maturing) update your system to get last fixes (this is the first run of the recent distribution !). Just do it.
    1. apt-get update
    2. apt-get upgrade
  8. Install nvidia propietary drivers: apt-get install nvidia-304 (the newest version supported by my 'oldie' card)
  9. Accept installation
  10. Just reboot.
  11. Done (it has autodeleted my custom xorg.conf file, that I copied from a pendrive: not really needed)
  12. Dual monitor running fine with nvidia propietary drivers. Again, what's up with nouveau ?

Tags: black screen video mode hangs boot grub2 settings configure install Linux MInt 17 16 15 14 13 Mate Ubuntu
Created: 4 years ago.
Last edited: 2 years ago.
Reviewed: 4 years ago.
Read 0 times.

Comments
4 months ago

mrDBUG
Mint 18 Cinnamon, Dell Inspiron 3552 ubuntu edition, Intel CPU integrated graphics, on boot of install USB black screen - gets past this with Nomodeset etc, however same problem persists inside of installed system, all updates done on Mint18. Only thing I havent done is BIOS update because Im afraid Ill brick my laptop.
Here is my forum post:
https://forums.linuxmint.com/viewtopic.php?f=59&t=226527
 
4 months ago

mysoomro
Does it work with Linuxmint 18 as well.

My system showed all different results.
still couldn't go beyond that blinking cursor.
 
8 months ago

mcbro
I may tentatively have solved this, inasmuch as for the past two days I was able to boot into Linux Mint 17.3 without the black screen and associated freeze.

To get there I upgraded my kernel to linux 4.4.0-14. I also updated my Nvidia driver to version 364.12, but the driver upgrade did not initially help. It was the kernel upgrade that seemed to at least temporarily stop the crashes.
 
8 months ago

mcbro
Months later this is still a problem for me. I've been sidestepping the issue somewhat by shutting down in hibernation mode and then rebooting. Unfortunately recently this is only working about 50 % of the time.

I have an Nvidia 770 GTX card. Driver changes haven't really addressed this. Once I'm in Mint runs flawlessly. Something is messed up during the boot sequence.
 
10 months ago

GOGuy
Mint 17.3 Cinnamon 64-bit produced exactly the same problem on an HP tower with an AMD E2-3200 dual-core processor, (what AMD calls an APU). This family of processors have an integrated Radeon graphics processor (HD 6370D in mine) that xserver-xorg-video-ati (the default driver) recognises but can't handle (ERROR - no UMS support in Radeon module). This PC has Windows 7 factory-installed on it, graphics work perfectly.

To get a display on which I could at least see what I was doing (more or less, at 640 x 480!), I used nomodeset as described above. I was then able to install Mint 17.3 as a dual boot (not straight forward - and completely daunting for any newbie).

To fix the graphics problem permanently, I ran Update Manager (twice) to make sure the new installation had all the latest patches. Then used Driver Manager to change the graphics driver to fglrx-updates. Reboot and the graphics are now fine on this basic 1024 x 768 monitor.

Ubuntu 10.04 was problem-free on this (spare) PC. About three years ago I tried to upgrade it to Mint 17.1. This and any Ubuntu-based release after 10 produce exactly the same problem.

Mint was supposed to be a Linux distro for people who just wanted an alternative to throwing away perfectly good hardware. Many thousands of PCs with these AMD processors will have been produced, but they are in effect unusable with Mint.
 
11 months ago

mcbro
@TheJJ  The alt arrowleft and alt arrowright scheme did not work for me. I'm not sure why.

Also the nomodeset solution doesn't work for me either. I am at a mode wherein if I use the 2nd grub menu entry item for recovery and then choose to resume the boot it does seem to boot correctly.
 
11 months ago

BlueLine92
I ran into this running Linux Mint 17.2 XFCE on my HP Mini 110. I upgraded and it refused to boot correctly, so I ended up adding the NOMODESET to the GRUB boot config file and this seems to have corrected it.

It may not be the most elegant solution, but it works. What bothers me is the older version I had on it worked fine right out of the gate.
 
1 year ago

mcbro
So far this is not working for Linux Mint 17.2. I have an Nvidia Gtx 770 card and a samsung monitor.

I can eventually get in via a recovery mode root access and then running lightdm or startx or it's equivalent.

In the past upgrading the drivers to the latest proprietary offerings via an ubuntu repository for nvidia worked well to fix this. However after having done this recently to the nvidia-352 drivers, after some time it started happening again.

There is a fundamental bug in the start up screen that has never been addressed I think. But there aren't enough people suffering from this to warrant anyone trying to fix it.
 
1 year ago

bmac6446
I have an older Nvidia GeForce 8400 running in my machine. It constantly causes a black screen upon boot up. I've had to press Esc when it initiates a boot, then scroll down to Recovery Mode and press Enter. I then let it resume with a normal boot up.
I assume that the kernel and video driver are not agreeing with each other.
 
4 years ago

AlbertP
Your text about modeset is not exactly right. Modesetting drivers are not the same as X.org drivers. r128 and nvidia are not kernel mode-setting drivers, you won't change anything on systems using those X.org drivers by including nomodeset. i915, radeon and nouveau are right; but since nomodeset works for all three, no need to know what hardware you have.  
4 years ago

gorade
Thank you! Next time I will try this. That black screen is a recurring annoyance. I have had to reinstall the whole system due to those crashes caused by mismatch. Now I hope this will be a more convenient way  

Other tutorials from slackjp