How to enable Wi-Fi Access point on Mint 17

gas_85
  5 years ago
  6

Hallo, today we will make from our Linux Mint 17 machine a Wi-Fi access point, for this we do not need any additional software, just easy as 1-2-3:

1. Go to Main Menu -> Preferences -> Network Connections click on Add and choose Wi-Fi. Choose a network name (SSID), Infrastructure mode. Go to to Wi-Fi Security and choose a WPA/WPA2 Personal and create a password. Go to IPv4 settings and check that it is shared with other computers.

2. Do sudo vi /etc/NetworkManager/system-connections/YOUR_CONNECTION_NAME and change mode=infrastructure to mode=ap and save it.

3. Click on Network Manager near clocks and choose connect to hidden wireless network --> choose your connection --> enjoy.

 

P.S. If it does not work, run iw list and check in Supported interface modes: * AP, if you do not have AP there, probably your Wi-Fi card does not support this mode.

Comments
adelejkruger 1 year ago

Thank you very much! Worked perfectly on Linux Mint 18.1 MATE


te36 2 years ago

Instructions do not work for me, Mint 17:
a) "click on network manager near clocks" -> there is only an icon called "connect to the wired network" in the bottom right corner.
b) when i click on that icon i see a list of wired/wireless connections plus "network settings", "network connections"
c) when i click on "network settings" a window called "networking" (part of settings" pops up.
d) On that window there is a button "connect to a hidden network"
e) when i click on that button, i can select my connection and then click "connect"
f) Unfortunately, it does not work then: My linux mint system itself only says "connecting". On another system where i try to connect to the SSID, it does not work - it asks for password, but then it does not work.

In my experience, every time Ubuntu Network Manager gets involved, stuff does not work. I hope i can find a pure CLI based tutorial instead.


alper_034 2 years ago

thanks, very easy with Mint 18.1


puigpuig 2 years ago

The idea is: if you have a wired connexion to the PC, how to create a Hotspot with Linux Mint? The wifi connexion that you get from this hotspot works well with Android phones and tablets.

Further explanation of Point 3: Click on Network Manager near clocks and choose under "Network Preferences" ("Preferencias de Red in Spanish) the button that says: "Connect to hidden wireless network", then choose your connection.


ffacualvarez 3 years ago

I find the problem and get the solution. It's working. Thank you


ffacualvarez 3 years ago

Hi. I'm not so good in terminal. Can somebody give me a step by step explanation about the second part?


farque 4 years ago

Can't find hidden network option?
left click the wifi icon in systray -> Network Settings -> wireless
Below the selection of wifi networks is a button 'connect to hidden network'. Click it, scroll through the list to YOUR_CONNECTION_NAME and select. Done.


farque 4 years ago

sudo gedit
instead of sudo vi for a notepad like gui text editor


farque 4 years ago

THIS IS BRILLIANT FOR ANDROID i.e. PC -> ANDROID SHARED INTERNET.

Because - the built in hotspot mode in linux mint does not work with android; android does not support ad hoc wifi natively. Even with root and editing wpa_supplicant.conf I was unable to connect to the ad hoc hotspot built in to linux mint.

However this does work. And it uses WPA2 not WEP so it's probably more secure too.

Big thanks.


jahid_0903014 4 years ago

This is quite useful, but alas!!, WiFi drops after sometime...


rahulrajpl 4 years ago

Works like Charm on my LM17.2!! Thanks alot man.


gunk 4 years ago

nice one man, i so wonder why the network manager doesn't(yet) give an option for ap...now my brother will stop bugging me.


NeoGeo64 4 years ago

This is one of the reasons that I switched to Linux, and Linux Mint in particular. My nice Dell XPS 8700 came with Windows 8 (upgraded to 7 later down the road) and the Dell drivers DVD came with a "HotSpot" program.

It sucked. It would disconnect all the time. The drivers for my wireless card SUCKED under Windows and are ROCK SOLID under Linux. I backed up all of my prized pix and vidz one day and ran a Boot and Nuke program to wipe all traces of filesystems and data off my hard drive. In short, my disk drive was factory fresh.

Then I inserted my Linux Mint install DVD and rebooted. I installed Linux Mint 17.1 back in December 2014. It is July 2015 and I still run Linux. Version 17.2 was released about a week ago and I've just seamlessly upgraded to that with the upgrade manager, which is another amazing feature of Linux Mint.

Anyways, I love having my Linux PC do everything I want it to in addition to acting as a rock solid WiFi hotspot.

If they started charging $200 a copy of Linux Mint I'd pay it. I love my Mint. I love it a lot!


tarkk 4 years ago

Worked fine.
Thanks


gas_85 4 years ago

You need to check VI tutorial, shortly it is goes with you pointer till "infrastructure", press "x" till you delete it and and then press "i" to insert "ap" instead. Then ESC, ":" and print "wq". But BETTER CHECK VI MANUALs.


gas_85 5 years ago

"Parameters on my system is Preferences. WI-FI Protection is WI-FI Security on my system" can be, I did translation, because I'm using Russion Mint:)

I did not catch your point about HP and USB wifi. Did you setup AP on one system and than use HP with an USB wifi? If yes, than it is ok if you can connect to the network.


pwoody82 5 years ago

I am running newly installed mint-17
I went thru step 1. Parameters on my system is Preferences. WI-FI Protection is WI-FI Security on my system. I have a wireless network up so I used it's name, but I did not have to. I changed it to something else without affecting the connection. I selected infrastructure mode. In security, I chose WPA & WPA2 personal and entered a password (assigned to the network previously). Again, the password could have been anything and I changed it. Save became available so I did so.

I am running an HP Desktop system with no built in wifi. My wifi is actually a USB 2.0 plugin I got on Ebay. In my case I did not have to do step 2 or 3, I was able to click the Icon in the taskbar where my local net was listed. When I clicked on that, I was asked for the password for the network (not the password I assigned in step 1) and connected right into the web.

The WI-FI icon appeared in the taskbar after the save, clicking on it showed my local net and a couple of outside networks. I did not have to go thru step 2 or 3. Rebooting the system found the wifi still working. On my laptop, clicking the icon in the taskbar shows all networks the system sees including hotspots. Clicking on a hotspot will take you to it and you can access it if you pass local restrictions.


jahid_0903014 5 years ago

remoulders method won't do the job, but this tutorial might. I am gonna check it. The option "Use as Hotspot" creates an hotspot with ad-hoc network not access point.


gas_85 5 years ago

That was a problem - no "Use as Hotspot" in my system. I checked everything, all other tutorial satrting with a "lets install hostapd..."


remoulder 5 years ago

Or just click "Use as Hotspot" in network settings.